Webové stránky K5
Články zobrazeny celkem: 1239133x  
Nabídka
Úvod
Přehled
K5
Masakr
Tipy
Odkazy
Vyhledávání

Reklama

Peklo upgradu verzí Tisk E-mail
Hodnocení čtenářů: / 0
SlabéVynikající 
Napsal K5   
Sunday, 24. August 2014
Jednoho krásného dne přestaly tyto mé stránky fungovat, protože přestárlý webhostingový server byl nahrazen novým na nové adrese.

A samozřejmě, s novějším hardwarem přišly i novější verze softwaru, pro mě kritický http server Apache a interpretr PHP. Migrace obsahu sice proběhla, ale nekompatibilita verzí byla příliš veliká a tak se místo stránek zobrazovalo jen chybové hlášení. Rychle to opravit nešlo a opravovat to pomalu, po kouskách, se mi moc nechtělo. Nakonec to trvalo dva roky, než jsem všechny nepodporované a změněné direktivy a příkazy přepsal na ty fungující a stránky se konečně rozběhly.

Upravit konfiguraci Apache nebylo až tak pracné, jenom se to prostě muselo udělat, ale PHP, to bylo to doslova peklo. Těch nutných úprav bylo strašně moc a navíc, PHP není zrovna jazyk, ve kterém bych programoval denně. Vlastně v něm neprogramuji téměř vůbec, jenom když už není jiného zbytí, takže ano, přiznávám, že ho vlastně až tak dokonale neovládám.

Já chápu, že se nové verze nevydávají jen tak pro zábavu, ale že opravují objevená bezpečnostní rizika a přinášejí nové funkcionality. Pro co ale nemám pochopení je to, když se "změní filozofie." Třeba Perl 6 není kompatibilní se svým předchůdcem. Proboha proč? Proč musím přepisovat všechny mé perlové skripty a programy? A tím nemyslím najdi a nahraď X za Y, ale opravdu přeprogramovat! S PHP je to podobné. Způsob X už není nadále podporován, použijte metodu Y... Děkuji nechci.

 
< Předch.   Další >

Google

Reklama

Nahlédněte
Futurama
BSG
MAME
SORD M5
VMware
Total Commander
ALIX a m0n0wall
Cisco PIX
Nejnovější
Nejčtenější
Viz též
   Úvod arrow K5 arrow Taxem zase jednou něco dělal arrow Peklo upgradu verzí
Powered by Joomla!